Still can't play the campaign

We'll help you troubleshoot issues with Battlefleet Gothic: Armada.
Daddy Frost
Posts: 10
Joined: 16 April 2016, 20:54

Still can't play the campaign

Postby Daddy Frost » 07 June 2016, 09:12

I start up the campaign and it tosses me into the first tutorial mission. But at the point when your ship gets up next to the station nothing happens. It just sits there...doing nothing. No updates or anything. There also seems to be a duplicate of the starting ship just sitting of the edge of the map doing nothing. I have tried the suggestion on the forums, though my media player was already up to date. I have tried reinstalling...twice. Nothing.

Oh there are no opening vids or narrations or anything either when I click new campaign, it just tosses me into the mission, though since it seems to be broken I wouldn't know if there are supposed to be any at that point regardless.

(Former) Alpha Tester
Posts: 16
Joined: 22 October 2015, 16:28

Re: Still can't play the campaign

Postby starscream » 07 June 2016, 23:15

i have had same problem since i brought game either they no idea how to fix it or dont care im hoping they working on it and just taking a lot longer than expected

User avatar
Focus Team
Posts: 438
Joined: 27 October 2015, 14:51

Re: Still can't play the campaign

Postby Focus_Jolan » 09 June 2016, 13:47

Hi guys,

Sorry for this inconvenience.
We'll try to fix it on our side but we never experienced that.
So it's really difficult to be sure of a possible fix of it.
We're testing a solution.
Maybe a fix soon.

Thank you.
Jolan - Focus Team

Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest