Page 1 of 1

Major Performance Issues (Mouse Lag/Audio Crackle/Computer Performance Affected)

Posted: 04 April 2016, 23:41
by Slywyn
So I just bought this game about an hour ago and I've only started it twice. Currently it's closed, and I don't really want to open it again until I can find a potential fix for this/these issues(I don't know if it's multiple issues compounding each other or if it's one large issue with multiple symptoms).

Basically- Downloaded the game, started it, went into the options menu. Set the game to run Windowed-Fullscreen, and set graphical presets to High.

When I attempted to start a new campaign, I was met with extensive audio crackle throughout the opening cinematic. Whatever, that's fine, just skipped it. However, when I got into the game, the audio crackle continued, the framerate lagged significantly, as did audio and input from the game itself. That's when the worst symptom set in.

I found myself unable to move my mouse faster than a snail's pace, and this continued when I attempted to shut the game down(As obviously something very wrong was happening). I was unable to start task manager, and eventually my computer became unresponsive. The mouse lag continued throughout.

When I restarted my computer and attempted to run the game again(To see if there was any way I could make it playable), I set the game to run in Fullscreen, and set graphical presets to low.

I was able to complete the first mission(And watch the opening cinematic I missed the first time) with only very minor audio crackle.

However, after the first mission ended and the cutscene for the second began, the audio crackle returned, and 5-10 seconds into the cutscene, the visuals and audio froze. However, the subtitles along the bottom of the screen continued to run in what I assume to be their normal timings. I attempted to let the cutscene play(Perhaps it was just not performing well?) but perhaps 10 seconds after the subtitles ceased it brought me to the dialogue box and screen for the second mission where you can see Port Maw, after Spire has been promoted.

The mouse lag and computer issues have not returned, but I don't feel particularly safe running the game at this point until I figure out what caused the initial problem.

I have included a DXDiag here: http://pastebin.com/vKvhBDFA Hopefully that assists in figuring out the problem.

Also, I don't know if this helps, but I experienced these same exact issues with XCom: Enemy Within. They were not present in the base game, they only occurred when I attempted to start the expansion. I never found a solution for those problems.

Re: Major Performance Issues (Mouse Lag/Audio Crackle/Computer Performance Affected)

Posted: 05 April 2016, 00:50
by Dust Sniffer
Have you tried toggling VSync?

Re: Major Performance Issues (Mouse Lag/Audio Crackle/Computer Performance Affected)

Posted: 05 April 2016, 01:12
by Slywyn
Vsync has never been turned on.

Edit: Just for the sake of trying(And to try a tip from a friend), I returned to the High settings and Windowed-Fullscreen, but then set them to Custom, and turned Anti-Aliasing to Low.

The mouse-lag and computer performance issues did not return, but cutscenes resumed crackling. The second mission cutscene got further(From the 'ship approaching the station with the nose cone in view' to 'Spire standing at the desk, top down') but then resumed the same behavior as before where Audio and Visuals did not work but Subtitles continued playing as normal.

Re: Major Performance Issues (Mouse Lag/Audio Crackle/Computer Performance Affected)

Posted: 05 April 2016, 15:14
by Slywyn
Just to note, the issues continue and I haven't been playing the game and won't risk playing it until they're figured out.

I don't want to refund but if I can't figure out what's causing these issues I might have to, just because I don't want to keep a game I cannot play safely.

Re: Major Performance Issues (Mouse Lag/Audio Crackle/Computer Performance Affected)

Posted: 05 April 2016, 16:43
by Dust Sniffer
One other person managed to fix the cutscenes by activating VSync, try it out.

Re: Major Performance Issues (Mouse Lag/Audio Crackle/Computer Performance Affected)

Posted: 05 April 2016, 17:13
by Slywyn
Hi! After contacting Customer Support via Email(And activating Vsync!) the problems have disappeared. No crackle, no weird cutscene drops, no performance issues.

I don't know whether it was fixing Vsync, or updating drivers(Thanks CS for checking my DXDiag!), but the game now performs splendidly.

If anyone experiences issues like mine, I would suggest checking your drivers(And trying Vsync!) because that's what fixed the issues for me.

Thank you for the assistance.